Strona główna > System > Windows 7 Professional – jak wgrać spolszczenie systemu?

Windows 7 Professional – jak wgrać spolszczenie systemu?

19 Sierpień 2009

Wczoraj w moim uczelnianym MSDN AA pojawiła się angielska wersja Windows 7 Professional RTM. Tuż obok została zamieszczona płyta Windows 7 MUI Language Pack DVD. Oczywiście postanowiłem zainstalować nowy system, mimo że przeglądając internet natrafiłem na informację, jakoby wersja Pro nie wspierała zmiany języka systemu. Chwila googlowania i miałem już sposób na obejście tego. Nie uśmiechało mi się ściągać prawie 2GB paczek językowych, więc udałem się na stronę My Digital Life gdzie pobrać można pojedyncze paczki językowe.

Następnym krokiem jest wykonanie tych czynności:

  1. Start Menu -> Wpisujemy cmd
  2. Klikamy na CMD.exe prawym przyciskiem myszy i wybieramy Run as administrator
  3. Wpisujemy:
    DISM /Online /Add-Package /PackagePath:(ścieżka do lp)

    Czyli np.:

    DISM /Online /Add-Package /PackagePath:C:\W7-RTM-x86-pl-pl\pl-pl\lp.cab
  4. Kiedy poprzednia operacja się zakończy wpisujemy:
    bcdedit /set {current} locale pl-PL

    i następnie:

    bcdboot %WinDir% /l pl-PL
  5. Ostatnią czynnością jest wejście w rejestr i przejście do klucza:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\MUI\UILanguages

    i usunąć klucz

    en-US
  6. Restartujemy system i cieszymy się polską wersją Windows 7 RTM Professional.

Na podstawie porady Piotra z forum TechIT http://forum.techit.pl/viewtopic.php?f=4&t=384&p=2176#p2176

Paczka dla systemów 32 bitowych: W7-RTM-x86-pl-pl.zip

Paczka dla systemów 64 bitowych: W7-RTM-x64-pl-pl.zip

P.S. Osobiście paczka 32 bit nie chciała mi się zainstalować i byłem zmuszony spróbować z płytki DVD (i to się powiodło), ale wydaje mi się, że wiem na czym polegał mój błąd. Prawdopodobnie paczkę należy skopiować do folderu o nazwie pl-pl, aby narzędzie DISM rozpoznało dla jakiego języka jest plik lokalizacyjny. Wersji 64 bit nie sprawdzałem. Na dowód że sposób działa, przedstawiam zrzut z Właściwości systemu

wlasciwosci systemu win7pro

Aktualizacja 19 wrz 2009 2009 14:48:

Wygląda na to, że paczki zostały usunięte z Depositfiles.com ze względu na prawa autorskie. Znalazłem jednak linki bezpośrednie do paczek językowych ze strony Microsoftu.

Paczka dla systemów 32 bitowych: windows6.1-kb972813-x86-pl-pl_9199018040692bc732a590e9b092a18120d326b2.exe

Paczka dla systemów 64 bitowych: windows6.1-kb972813-x64-pl-pl_6b228326c2f7ef6406242671600b499746ff3454.exe

Instrukcja za MyDigitalLife.com:

Po ściągnięciu pliku exe na dysk uruchamiamy go, aby wypakować plik .cab z paczką językową. Dalej postępujemy wg instrukcji zamieszczonej u góry wpisu.

Prawdopodobnie podany tu sposób nie działa. Wciąż szukam rozwiązania, linki powinny pojawić się w najbliższym czasie.

Aktualizacja 2 19 wrz 2009 2009 18:38:

Paczka dla systemów 32 bitowych: W7-RTM-x86-pl-pl.zip

Paczka dla systemów 64 bitowych: W7-RTM-x64-pl-pl.zip

Policyjna blokada serwisu Odsiebie.com spowodowała wygaśnięcie linków do paczek. Jeden z czytelników podał jednak alternatywne rozwiązanie (dzięki H). Uprzedzam że podany sposób nie został przeze mnie sprawdzony.

  1. Ruad
    30 Sierpień 2009 o 11:59:52

    Uwaga na błędy! Po pierwsze w drugim kroku jest błąd w ścieżce przykładowej. Brak jest dwukropka po literze napędu. Po drugie błąd jest w kluczu. Mianowicie prawidłowo jest: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\MUI\UILanguages

  2. blaast
    30 Sierpień 2009 o 12:11:22

    Ruad, dzięki za uwagi, już poprawione ;)

  3. x
    31 Sierpień 2009 o 15:40:05

    thx, przydalo sie

  4. Snake
    6 Wrzesień 2009 o 16:14:23

    Działa na systemie 64 bit. Dzięki wielkie.

  5. hary
    8 Wrzesień 2009 o 00:11:39

    Działa. Dzięki.

  6. opi
    13 Wrzesień 2009 o 16:16:54

    Potwierdzam… z systemem z MSNAA z uczelni ENG W7Pro.

    Wszystko działa, nie ma ani jednego słówka po angielsku :)

  7. eliyahu
    13 Wrzesień 2009 o 18:25:22

    czy można usunąć paczkę jezykową z miejsca „c:\pl-PL” ? .. czy musi ona tam pozostać ?

  8. blaast
    13 Wrzesień 2009 o 20:02:24

    Pierwsza myśl: oczywiście że można xD
    Ale dla pewności swojej i Waszej sprawdziłem, po usunięciu paczki pl system uruchamia się poprawnie z językiem polskim. W pliku lp.cab są tylko pliki (bądź instrukcje) które Windows „instaluje” narzędziem DISM, a więc „instalkę” lp.cab wraz z folderem można po całej operacji usunąć

  9. Sol
    18 Wrzesień 2009 o 13:28:08

    Dlaczego nie można już pobrać paczek językowych? ma ktoś jakieś działające linki?

  10. Sola
    19 Wrzesień 2009 o 16:05:45

    Ma ktoś działające linki do paczek Win7 PL x64? bo podane tutaj niestety nie działają :(

    A na MyDigital jest tylko paczka .exe która jakoś nie chce mi się rozpakować? Chyba ze trzeba się z nią jakoś inaczej obsłużyć :( bo po uruchomieniu pojawia się jakieś archiwum cab na chwilę a potem znika… :(

  11. blaast
    19 Wrzesień 2009 o 16:18:59

    Nie mam czasu się zagłębiać dokładnie, ale wygląda na to że zostały usunięte ze względu na prawa autorskie. Zobaczymy co da się zrobić w tym temacie ;)

    Edit:
    Linki poprawione

    Edit2:
    Faktycznie, coś się te exeki nie chcą rozpakowywać. Poszukam rozwiązania

    Edit3:
    Częściowe rozwiązanie gotowe, 64 bit będzie jutro

    Edit4:
    Oba linki gotowe

  12. Sola
    23 Wrzesień 2009 o 09:08:51

    Dzięki, już wszystko śmiga…

    Pozdrawiam

  13. lukasz_1_2
    28 Wrzesień 2009 o 21:42:46

    witam
    U mnie nie działa
    Ciągle wyskakuje ERROR 87
    Prosze o pomoc!!!

  14. 1 Październik 2009 o 09:36:07

    Zadziałało. Dziękuję bardzo, to cenna informacja. Pozdrawiam!

  15. rafirr
    8 Październik 2009 o 21:01:36

    witam! mam problem po wpisaniu pierwszej linii wyskakuje mi error: 740 co robię nie tak?? też mam windowsa z MSDNAA tzlko x86

  16. Tomek
    15 Październik 2009 o 17:04:57

    rafirr wejdź do Contro Panel>User Acounst and Family safty>User accounts>change users account controll settings. i tam zjedź suwakiem na sam doł:) pomoże.

  17. PaFcio
    15 Październik 2009 o 18:10:56

    witam. Mam ten sam problem co rafirr. To co poleciles Tomek u mnie nie pomoglo. Ciagle ten sam blad. Prosze o pomoc. Pozdrawiam.

  18. blaast
    15 Październik 2009 o 19:33:50

    Poprawiłem ciut opis żeby był bardziej zrozumiały. Więcej nie jestem w stanie pomóc, ale od czego mamy google ;)

  19. Tomek
    15 Październik 2009 o 21:16:04

    Pafcio a robiles restart?
    a moze jak włączasz CMD to docelowo jesteś w katalogu C:\windows\system32 a powinieneś być w katalogu z polonizacją u mnie to bylo c:\pl-pl\

  20. Buszu
    17 Październik 2009 o 12:16:29

    Wielkie dzięki za instrukcje,wszystko działa jak najbardziej poprawnie:))

  1. No trackbacks yet.
Możliwość komentowania jest wyłączona.
%d bloggers like this: